Shiffali Grover

CQ5/AEM, Java

Issues while Migrating from Java6 to Java8 in AEM 6.1

Recently while working on AEM 6.1, I had to move from Java 6 to Java 8. Simply changing the Java version in POM led to some issues with OSGi services. Specifically, those services that were using @Reference annotation were not getting active and remained in "satistied" state. Here are all the steps I followed firstly to change Java...

30-Oct-2015